MT4 & MT5 to Stop Supporting Windows XP, 2003 and Vista. Here is what you need to do.

July 14, 2017

Your device might need an update for this.

MT4 & MT5 to Stop Supporting Windows XP, 2003 and Vista. Here is what you need to do.

We would like to inform you that, as of Sunday, October 1, 2017, the MetaTrader 4 & 5 platforms will no longer support outdated versions of the Windows operating system including Windows XP, Windows 2003 and Windows Vista.

MetaQuotes has made this decision as these outdated operating systems are no longer supported by Microsoft and feature a number of dangerous vulnerabilities.

How Does This Affect Me?

The minimum required operating system to run the MT4 and MT5 platforms will now be Windows 7, although MetaQuotes strongly suggest using the 64-bit version of Windows 10, to fully benefit from the latest updates and support.

If your operating system does not meet the new minimum requirements, FXPro offers mobile and web-based versions of the MT4 and MT5 platforms.

These include the FxPro MT4 WebTrader and FxPro MT4 for Mobile, as well as the FxPro MT5 WebTrader and FxPro MT5 for Mobile.

50 USD for Free

Free 123 USD

30 USD for Free

25 USD for Free

300 USD for Free

100 USD for Free

Partner brands

Hercules